IPB

Здравствуйте, гость ( Вход | Регистрация )

> Внимание!

При создании сообщения обязательно указывайте версию програмного продукта «АТОЛ: Рабочее место кассира» и операционной системы.

В противном случае мы оставляем за собой право не отвечать на поставленый вопрос!

 
Добавить ответ в эту темуОткрыть тему
ошибка программирования реквизита 1023
Максим Парфенов
сообщение 10.12.2021, 16:24
Сообщение #1


Прохожий


Группа: Новички
Сообщений: 16
Регистрация: 9.12.2021
Пользователь №: 378 829



Добрый день!
Название ККТ: АТОЛ 11Ф, Версия прошивки: 5.8.1, Драйвер: 10.9.0.8
Версия ФФД ККТ: 1.2, Версия ФФД ФН: 1.2, Версия ФФД: 1.2
Пытаюсь пробить обувь с маркой в 1С 7.7
При проверке марки выдает ошибку 148 - Ошибка программирования реквизита 1023
но если fptr.LIBFPTR_PARAM_MARKING_CODE_STATUS ставлю 2 то resultcode = 0, хотя проверку марка так и не проходит, чек был напечанат с буквой [М-] 7053
Подскажите пжл в чем ошибка?

я делаю вот так:

true = 1;
true2 = -1;
status2 = 1;
Истина = 1;

Если СокрЛП(СписокТоваров.Марка) <> "" Тогда
КМ = СокрЛП(СписокТоваров.Марка);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE_TYPE, fptr.LIBFPTR_MCT12_AUTO);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE, КМ);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE_STATUS, status2);
fptr.setParam(fptr.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
fptr.setParam(fptr.LIBFPTR_PARAM_MEASUREMENT_UNIT, fptr.LIBFPTR_IU_PIECE);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_WAIT_FOR_VALIDATION_RESULT, Истина);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_PROCESSING_MODE, 0);
fptr.beginMarkingCodeValidation();

resultcode = fptr.errorCode();

Если resultcode <> 0 Тогда
ОписаниеРезультата = Fptr.ErrorDescription();
КодОшибки = Fptr.ErrorCode();
рез = 0;
Fptr.cancelMarkingCodeValidation();
Fptr.cancelReceipt();
Отключиться10(Fptr, 0);
Возврат 0;
КонецЕсли;

//ЗДЕСЬ НЕПОНЯТНО ЧЕМУ ДОЛЖЕН БЫТЬ РАВЕН "fptr.LIBFPTR_PARAM_MARKING_CODE_VALIDATION_READY"? Отладчик показывает "-1", а в логах кассы значение "true"
Пока true = 1 Цикл
fptr.getMarkingCodeValidationStatus();
Если fptr.getParamBool(fptr.LIBFPTR_PARAM_MARKING_CODE_VALIDATION_READY) = true2 Тогда
Прервать;
КонецЕсли;
КонецЦикла;

РезультатПроверкиКИЗ = fptr.getParamInt(fptr.LIBFPTR_PARAM_MARKING_CODE_ONLINE_VALIDATION_RESULT);

// Подтверждаем реализацию товара с указанным КМ
ответ = fptr.acceptMarkingCode();
Если ответ <> 0 Тогда
ОписаниеРезультата = Fptr.ErrorDescription();
КодОшибки = Fptr.ErrorCode();
рез = 0;
Fptr.cancelMarkingCodeValidation();
Fptr.cancelReceipt();
Отключиться10(Fptr, 0);
Возврат 0;
КонецЕсли;

Fptr.setParam(Fptr.LIBFPTR_PARAM_MARKING_CODE,КМ);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE_STATUS, Status2);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_CODE_ONLINE_VALIDATION_RESULT, РезультатПроверкиКИЗ);
fptr.setParam(fptr.LIBFPTR_PARAM_MARKING_PROCESSING_MODE, 0);

КонецЕсли;

//здесь начинаю регистрацию товара
Fptr.setParam(Fptr.LIBFPTR_PARAM_COMMODITY_NAME, ЗаменитьСпецСимволы(Товар2));
Fptr.setParam(Fptr.LIBFPTR_PARAM_QUANTITY, Quantity);
Fptr.setParam(Fptr.LIBFPTR_PARAM_POSITION_SUM,Vsego);
Fptr.setParam(Fptr.LIBFPTR_PARAM_INFO_DISCOUNT_SUM, Skidka);
Fptr.setParam(Fptr.LIBFPTR_PARAM_PRICE, Price);
Fptr.setParam(Fptr.LIBFPTR_PARAM_TAX_TYPE, Fptr.LIBFPTR_TAX_NO);

Fptr.setParam(1212, 1);
Fptr.setParam(1214, 4);

Ответ = Fptr.registration();
Если Ответ<>0 Тогда
ОписаниеРезультата = Fptr.ErrorDescription();
КодОшибки = Fptr.ErrorCode();
рез = 0;
Fptr.cancelReceipt();
Возврат рез;
КонецЕсли;
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
АТОЛ: Царюков Ро...
сообщение 10.12.2021, 16:29
Сообщение #2


Тех.поддержка
********

Группа: Администраторы
Сообщений: 58 046
Регистрация: 25.9.2008
Из: Москва
Пользователь №: 14 717



http://forum.atol.ru/index.php?showtopic=4...st&p=320570

и прошивку обновите до релизной 5.8.17


--------------------
ответы на 90% вопросов находятся в ДОКУМЕНТАЦИИ
еще 9% ответов ТУТ
P.S.: уважайте труд наших писателей - читайте мануалы
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Максим Парфенов
сообщение 11.12.2021, 15:48
Сообщение #3


Прохожий


Группа: Новички
Сообщений: 16
Регистрация: 9.12.2021
Пользователь №: 378 829



Спасибо. Разобрался.
1. не проходит проверка связи с сервером ИСМ в драйвере, в логах:
адрес указан, порт тоже

2021.12.11 15:43:18.976 T:00001320 INFO [FiscalPrinter] < LIBFPTR_PARAM_CHECK_MARKING_SERVER_READY (65859) = false

2. и дальше, в программе значение ответа:

fptr.getParamBool(fptr.LIBFPTR_PARAM_MARKING_CODE_VALIDATION_READY) = -1

в логах:

LIBFPTR_PARAM_MARKING_CODE_VALIDATION_READY (65850) = true
2021.12.11 15:35:42.720 T:0000119C INFO [FiscalPrinter] < LIBFPTR_PARAM_IS_REQUEST_SENT (65878) = true
2021.12.11 15:35:42.720 T:0000119C INFO [FiscalPrinter] < LIBFPTR_PARAM_MARKING_CODE_ONLINE_VALIDATION_ERROR_DESCRIPTION (65887) = "Ошибок нет"
2021.12.11 15:35:42.720 T:0000119C INFO [FiscalPrinter] < LIBFPTR_PARAM_MARKING_CODE_ONLINE_VALIDATION_ERROR (65849) = 0
2021.12.11 15:35:42.720 T:0000119C INFO [FiscalPrinter] < 2106 (2106) = 5
2021.12.11 15:35:42.720 T:0000119C INFO [FiscalPrinter] < LIBFPTR_PARAM_MARKING_CODE_ONLINE_VALIDATION_RESULT (65886) = 5

Я так понимаю, что должна пройти проверка марки в ИСМ и тогда марка спишется и чек правильно распечатается?
Как настроить связь с ИСМ? настройки проверял.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Максим Парфенов
сообщение 13.12.2021, 11:43
Сообщение #4


Прохожий


Группа: Новички
Сообщений: 16
Регистрация: 9.12.2021
Пользователь №: 378 829



Подскажите, как настроить связь с ИСМ? настройки проверял.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Добавить ответ в эту темуОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 5.10.2022, 8:03
 Яндекс цитирования  Rambler's Top100