IPB

Здравствуйте, гость ( Вход | Регистрация )

> Внимание!

Группа компаний «АТОЛ» информирует Вас о том, что с 4 июля 2011 года закрываются электронные форумы ГК «АТОЛ»,
посвященные дистрибутируемому и собственному оборудованию.
С 4 июля 2011 года данный раздел будет доступен только для чтения.

Для получения технической поддержки и сервиса мы рекомендуем всем партнерам зарегистрироваться в системе управления инцидентами Service Desk.

 
Добавить ответ в эту темуОткрыть тему
Типы оплат ТИС 77 и обработка Fr_comm.ert
arimar
сообщение 12.4.2011, 10:37
Сообщение #1


Прохожий


Группа: Новички
Сообщений: 3
Регистрация: 10.4.2011
Пользователь №: 26 717



День добрый! только вот не давно начал разбираться с 1С , Проблемка такая надо прикрутить в 1С ТИС 77 , чтобы можно было через обработку fr_comm.ert на принтер ЕНВД в чеке выводить разные типы оплаты!
Предыдущие топики которые были почитал!
1) http://forum.atol.ru/index.php?showtopic=1...ghlight=payment
2)http://forum.atol.ru/index.php?showtopic=1304&highlight=payment
почти все не понятно, может подскажите
если я буду писать в коде 1С обработке fr_comm.ert
CODE
Если (Получено > 0) И (Получено > СуммаЧека) Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ТипЗакрытия = 0;
Объект.Оплата();
Иначе
Объект.ЗакрытьЧек();
КонецЕсли;
Если ПолученоБезнал > 0 Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ТипЗакрытия = 1;
Объект.Оплата();
Иначе
Объект.ЗакрытьЧек();
КонецЕсли;

или же вот так

КонецЕсли;
CODE
Если (Получено>0) И (Получено>СуммаЧека) Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ОплатаСоСдачей();
ИначеЕсли ПолученоБезнал <> 0 Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ТипЗакрытия = 1;
Объект.Payment();
Иначе
Объект.ЗакрытьЧек();
КонецЕсли;


Да и зачем указывать метод Payment()? я так понял если у нас смешанный тип оплаты то тогда, а если не используется то можно ли просто написать ЗакрытьЧек()
?????????
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
arimar
сообщение 13.4.2011, 10:06
Сообщение #2


Прохожий


Группа: Новички
Сообщений: 3
Регистрация: 10.4.2011
Пользователь №: 26 717



Все решилось! wink.gif))) ну конечно тема не из этой ветки! Всего то требоввалось пару строчек кода написать!
Можно закрывать тему!
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Добавить ответ в эту темуОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 22.9.2018, 5:21
 Яндекс цитирования  Rambler's Top100