IPB

Здравствуйте, гость ( Вход | Регистрация )

> Внимание!

Группа компаний «АТОЛ» информирует Вас о том, что с 4 июля 2011 года закрываются электронные форумы ГК «АТОЛ»,
посвященные дистрибутируемому и собственному оборудованию.
С 4 июля 2011 года данный раздел будет доступен только для чтения.

Для получения технической поддержки и сервиса мы рекомендуем всем партнерам зарегистрироваться в системе управления инцидентами Service Desk.

 
Добавить ответ в эту темуОткрыть тему
Ошибка в Discountvalue, Не пробивается ЧекККМ в 1С
Vasix
сообщение 25.8.2010, 16:13
Сообщение #1


Прохожий


Группа: Новички
Сообщений: 5
Регистрация: 25.8.2010
Пользователь №: 22 220



Версия 1С:Розница 1.0.7.4
Версия Драйвера Атол 6.11
Фискальник Феликс 02К

При пробитии чека в документе ЧекККМ с использованием накопительной скидки:
Количество 12,825
Цена 155,00
Сумма 1 789,00 (Округляется до рублей)
Скидка 198,88 (10% + округление)

выводится сообщение "О разнице сумм в ленте чека и документе и ошибке в DiscountValue".
чек не пробивается.

В чем может быть проблема???
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Илья Золотарев
сообщение 25.8.2010, 16:17
Сообщение #2


выБывший
********

Группа: Пользователи
Сообщений: 2 996
Регистрация: 26.9.2007
Из: Москва
Пользователь №: 11 833



Цитата(Vasix @ 25.8.2010, 17:13) *
Версия 1С:Розница 1.0.7.4
Версия Драйвера Атол 6.11
Фискальник Феликс 02К
При пробитии чека в документе ЧекККМ с использованием накопительной скидки:
Количество 12,825
Цена 155,00
Сумма 1 789,00 (Округляется до рублей)
Скидка 198,88 (10% + округление)
выводится сообщение "О разнице сумм в ленте чека и документе и ошибке в DiscountValue".
чек не пробивается.
В чем может быть проблема???

Выкладывайте лог Драйвера ККМ.


--------------------
экс-сотрудник АТОЛ
"Féci quód potuí, faciánt melióra poténtes" ©
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Vasix
сообщение 25.8.2010, 16:26
Сообщение #3


Прохожий


Группа: Новички
Сообщений: 5
Регистрация: 25.8.2010
Пользователь №: 22 220



А где лежат логи?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Илья Золотарев
сообщение 25.8.2010, 16:31
Сообщение #4


выБывший
********

Группа: Пользователи
Сообщений: 2 996
Регистрация: 26.9.2007
Из: Москва
Пользователь №: 11 833



Цитата(Vasix @ 25.8.2010, 17:26) *
А где лежат логи?

По умолчанию: C:\Program Files\ATOL\Drivers\Bin


--------------------
экс-сотрудник АТОЛ
"Féci quód potuí, faciánt melióra poténtes" ©
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Vasix
сообщение 27.8.2010, 9:24
Сообщение #5


Прохожий


Группа: Новички
Сообщений: 5
Регистрация: 25.8.2010
Пользователь №: 22 220



CODE
25.08.2010 16:52:05 0001340235 1C_Interface.OpenCheck 4 -1 0 -1
0000000000 Driver.Set_CurrentDeviceNumber 4
25.08.2010 16:52:05 0000000000 Driver.GetStatus
25.08.2010 16:52:05 0000000000 Посылка команды ККМ: 00 00 3F
0000000031 Получен ответ: 44 30 01 10 08 25 16 54 40 03 01 02 07 68 0F 32 34 01 25 27 15 52 00 00 00 00 00 00 02 01
0000000000 Driver.Set_Mode 1
0000000000 Driver.Set_Password 30
25.08.2010 16:52:05 0000000000 Driver.SetMode
25.08.2010 16:52:05 0000000000 Посылка команды ККМ: 00 00 48
0000000000 Получен ответ: 55 00 00
25.08.2010 16:52:05 0000000000 Посылка команды ККМ: 00 00 56 01 00 00 00 30
0000000062 Получен ответ: 55 00 00
0000000000 Driver.Set_CheckType 1
25.08.2010 16:52:05 0000000000 Driver.OpenCheck
25.08.2010 16:52:05 0000000000 Посылка команды ККМ: 00 00 92 00 01
0000000016 Получен ответ: 55 00 00
25.08.2010 16:52:05 0000000000 Driver.GetStatus
25.08.2010 16:52:05 0000000000 Посылка команды ККМ: 00 00 3F
0000000031 Получен ответ: 44 30 01 10 08 25 16 54 40 03 01 02 07 68 0F 32 34 01 25 27 15 52 01 00 00 00 00 00 02 01
0000000000 1C_Interface.PrintFiscalString 4 25-192 Джуди Линолеум ПВХ 2,5м "Парма"(77,5)(м2) 12,825 155 1789 1 0
0000000000 Driver.Set_CurrentDeviceNumber 4
0000000000 Driver.Set_Name 25-192 Джуди Линолеум ПВХ 2,5м "Парма"(77,5)(м2)
0000000000 Driver.Set_Quantity 12,825
0000000000 Driver.Set_Price 155
0000000000 Driver.Set_DiscountValue 0
0000000000 Driver.Set_DiscountType 0
0000000000 Driver.Set_DiscountValue 198,875
25.08.2010 16:52:05 0000000000 Ошибка! ResultCode = -6 ResultDescription = "Недопустимое значение" BadParam = -112 BadParamDescription = "Ошибка в DiscountValue"
0000000000 1C_Interface.GetLastError
0000000000 1C_Interface.CancelCheck 4
0000000000 Driver.Set_CurrentDeviceNumber 4
25.08.2010 16:52:05 0000000000 Driver.CancelCheck
25.08.2010 16:52:05 0000000000 Посылка команды ККМ: 00 00 59
0000000891 Получен ответ: 55 00 00
0000291453 1C_Interface.Close 4
0000000000 Driver.Set_CurrentDeviceNumber 4
0000000000 Driver.Set_DeviceEnabled 0
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Илья Золотарев
сообщение 27.8.2010, 10:08
Сообщение #6


выБывший
********

Группа: Пользователи
Сообщений: 2 996
Регистрация: 26.9.2007
Из: Москва
Пользователь №: 11 833



Цитата(Vasix @ 27.8.2010, 10:24) *
25.08.2010 16:52:05 0001340235 1C_Interface.OpenCheck 4 -1 0 -1
...
0000000000 Driver.Set_DeviceEnabled 0

Судя по логу округления скидки не производится, и передается 198,875


--------------------
экс-сотрудник АТОЛ
"Féci quód potuí, faciánt melióra poténtes" ©
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Vasix
сообщение 27.8.2010, 10:16
Сообщение #7


Прохожий


Группа: Новички
Сообщений: 5
Регистрация: 25.8.2010
Пользователь №: 22 220



Цитата(АТОЛ: Илья Золотарев @ 27.8.2010, 11:08) *
Судя по логу округления скидки не производится, и передается 198,875


Текст с 1С:
Результат = мНетОшибки;

Если СуммаСоСкидкой = 0 Тогда
СуммаСоСкидкой = Окр(Количество * Цена * (1 - Скидка * 0.01), 2, РежимОкругления.Окр15как20);
КонецЕсли;

Если Не Объект.Драйвер.НапечататьФискСтроку(Объект.ИДУстройства, Наименование, Количество,
Цена, СуммаСоСкидкой, Отдел, НДС) Тогда
Результат = мОшибкаНеизвестно;
Объект.Драйвер.ПолучитьОшибку(Объект.ОписаниеОшибки);

ОтменитьЧек(Объект);
КонецЕсли;

Возврат Результат;

Вообще передается расчитанная сумма.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Vasix
сообщение 1.9.2010, 8:07
Сообщение #8


Прохожий


Группа: Новички
Сообщений: 5
Регистрация: 25.8.2010
Пользователь №: 22 220



Цитата(Vasix @ 27.8.2010, 11:16) *
Текст с 1С:
Результат = мНетОшибки;

Если СуммаСоСкидкой = 0 Тогда
СуммаСоСкидкой = Окр(Количество * Цена * (1 - Скидка * 0.01), 2, РежимОкругления.Окр15как20);
КонецЕсли;

Если Не Объект.Драйвер.НапечататьФискСтроку(Объект.ИДУстройства, Наименование, Количество,
Цена, СуммаСоСкидкой, Отдел, НДС) Тогда
Результат = мОшибкаНеизвестно;
Объект.Драйвер.ПолучитьОшибку(Объект.ОписаниеОшибки);

ОтменитьЧек(Объект);
КонецЕсли;

Возврат Результат;

Вообще передается расчитанная сумма.


Пожалуйста, необходима помощь!!!
Может, как-нибудь настроить фискальник сам?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Добавить ответ в эту темуОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 20.8.2019, 11:49
 Яндекс цитирования  Rambler's Top100