IPB

Здравствуйте, гость ( Вход | Регистрация )

> Внимание!

С 24.11.2009 поддержка по программному продукту Торговля24h осуществляется только на официальном форуме компании СофтБаланс http://www.dalion.ru/forum/

 
Добавить ответ в эту темуОткрыть тему
И снова весы Масса-К ВПМ 15.2-Ф1
serega2671
сообщение 31.8.2009, 11:53
Сообщение #1


Опытный
****

Группа: Пользователи
Сообщений: 518
Регистрация: 5.3.2009
Пользователь №: 15 942



Подскажите в чем может быть дело.

Конфигурация Торговля 24 часа к ней подключены весы Масса-К RS-232 и весы Масса-К ВПМ RS-232. На весах масса-к впм установлена последняя версия прошивки. Все весы загружаются нормально, но только вот если весы масса-к дозагружать, например и-з документа переоценка товаров то они прекрасно дазагружаются, а вот если тоже самое проделать с весами масса-к впм то они сделают следующее: удалят все товары , а потом загрузят мне из документа переоценки, если обработка то почему она не удаляет тогда список товаров из других весов масса-к? подскажите


--------------------

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
АТОЛ:Александр Д...
сообщение 31.8.2009, 12:19
Сообщение #2


Магистр слова
********

Группа: Менеджеры
Сообщений: 2 433
Регистрация: 8.10.2007
Пользователь №: 11 910



какой версии драйвер ВПЭ?

ситуация в тесте драйвера ВПЭ такая же? (масса-к дозагружается, а в масса-к впм стираются данные с весов и записываются новые).
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Бабурин Михаил
сообщение 31.8.2009, 13:15
Сообщение #3


Продукт-менеджер по системному ПО
*******

Группа: Пользователи
Сообщений: 1 770
Регистрация: 27.8.2007
Из: ГК АТОЛ
Пользователь №: 11 651



Что то мне подсказывает что это продолжение вот этой темы.

Ждем ответа от коллег из СофтБаланса, что скажут они по логике работы обработки загрузки весов.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
serega2671
сообщение 31.8.2009, 13:16
Сообщение #4


Опытный
****

Группа: Пользователи
Сообщений: 518
Регистрация: 5.3.2009
Пользователь №: 15 942



Цитата(АТОЛ:Александр Данилов @ 31.8.2009, 13:19) *
какой версии драйвер ВПЭ?

ситуация в тесте драйвера ВПЭ такая же? (масса-к дозагружается, а в масса-к впм стираются данные с весов и записываются новые).




1. Драйвер ВПЭ последней версии 6.13.0.788


В тесте драйвера дозагружаются не затирая старые, в тесте все нормально идет, а вот в т24 удаляет, хотя и обработку смотрел, но там ничего такого страшного нет, да и другие весы работают нормально, если бы дело в обработке то весы масса-к также бы сначала удаляли все а потом закидывали переоценку.


--------------------

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
serega2671
сообщение 31.8.2009, 13:26
Сообщение #5


Опытный
****

Группа: Пользователи
Сообщений: 518
Регистрация: 5.3.2009
Пользователь №: 15 942



Цитата(Бабурин Михаил @ 31.8.2009, 14:15) *
Что то мне подсказывает что это продолжение вот этой темы.

Ждем ответа от коллег из СофтБаланса, что скажут они по логике работы обработки загрузки весов.




Ну да, хотелось бы уже услышать, в чем все-таки дело, в самих весах чего или в обработке 1С T24

На драйвер я даже не думаю!


--------------------

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Бабурин Михаил
сообщение 31.8.2009, 13:55
Сообщение #6


Продукт-менеджер по системному ПО
*******

Группа: Пользователи
Сообщений: 1 770
Регистрация: 27.8.2007
Из: ГК АТОЛ
Пользователь №: 11 651



Ну раз весы из драйвера прогружаются корректно разными методами, думаю, в них тоже все в порядке.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
serega2671
сообщение 31.8.2009, 14:00
Сообщение #7


Опытный
****

Группа: Пользователи
Сообщений: 518
Регистрация: 5.3.2009
Пользователь №: 15 942



значит все-таки в обработке, которая по нажатию на кнопку загрузить вызывает метод драйвера подобный тому. что в драйвере "записать все в весы" , а не записать текущее PLU.

в каком именно месте вызывается этот метод драйвера, потому что посмотрел вроде все что можно уже. обработку: управление весами, Обслуживание_ВЕСЫ_CASLP_Атол54. в каком именно месте вызывается метод драйвера???


--------------------

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
serega2671
сообщение 31.8.2009, 14:23
Сообщение #8


Опытный
****

Группа: Пользователи
Сообщений: 518
Регистрация: 5.3.2009
Пользователь №: 15 942



Подскажите вроде нашел ответ. Сейчас весы дозагружаться стали, поправил обработку Обслуживание_ВЕСЫ_CASLP_Атол54 и вместо метода драйвера BeginAdd поставил SetRecord. Я правльно понял, что BeginAdd соответствует тому что я добавляю записи, стирая все что там уже есть и что соответствует в драйвере записи "Записать все в весы", а SetRecord соответствует дозагрузке и соответствует в драйвере записи "Записать текущее PLU"???


--------------------

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
АТОЛ: Царюков Ро...
сообщение 31.8.2009, 14:27
Сообщение #9


Тех.поддержка
********

Группа: Администраторы
Сообщений: 46 931
Регистрация: 25.9.2008
Из: Москва
Пользователь №: 14 717



Цитата(serega2671 @ 31.8.2009, 15:23) *
Подскажите вроде нашел ответ. Сейчас весы дозагружаться стали, поправил обработку Обслуживание_ВЕСЫ_CASLP_Атол54 и вместо метода драйвера BeginAdd поставил SetRecord. Я правльно понял, что BeginAdd соответствует тому что я добавляю записи, стирая все что там уже есть и что соответствует в драйвере записи "Записать все в весы", а SetRecord соответствует дозагрузке и соответствует в драйвере записи "Записать текущее PLU"???

о командах можно и в мануале почитать...
для этого их и пишут


--------------------

ответы на 90% вопросов находятся в ДОКУМЕНТАЦИИ
еще 9% ответов ТУТ
P.S.: уважайте труд наших писателей - читайте мануалы
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Михин Константин
сообщение 31.8.2009, 15:19
Сообщение #10


Постоялец
*****

Группа: Тех. поддержка
Сообщений: 668
Регистрация: 22.6.2006
Из: Санкт-Петербург
Пользователь №: 7 333



Обработка одинаково работает со всеми весами, но, теоритически можно попробовать закомментировать вызовы методов BeginAdd и EndAdd.


--------------------
Михин Константин, ВЦ "СофтБаланс"
Архитектор проектов
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
serega2671
сообщение 31.8.2009, 19:44
Сообщение #11


Опытный
****

Группа: Пользователи
Сообщений: 518
Регистрация: 5.3.2009
Пользователь №: 15 942



Цитата(Михин Константин @ 31.8.2009, 16:19) *
Обработка одинаково работает со всеми весами, но, теоритически можно попробовать закомментировать вызовы методов BeginAdd и EndAdd.



Но тем неменее, с весами масса-к впм обработка что-то отказывается работать также как со всеми. Как я понял, то весы масса-к впм понимают метод BeginAdd как загрузить поверх имеющихся товаров, а вот если я ставлю SetRecord то весы нормально дозагружаются: сейчас приведу кусок кода где и что меняю, и хотелдось бы услышать, что может быть "плохого" в том что я поменял, как я заметил, то разница всего лишь в том, что метод BeginAdd сначала записывает все в буфер, а по методу EndAdd начинается загрузка в весы всего списка товаров, сейчас же у меня весы грузятся параллельно, с выгрузкой.


Процедура ЗагрузкаТоваров()

ТаблицаТоваров = Форма.Параметр.Получить("ТаблицаТоваров");

Если ТипЗначенияСтр(ТаблицаТоваров) <> "ТаблицаЗначений" Тогда
Ошибка.Установить("Описание" ,"Неверный формат таблицы товаров!");
Ошибка.Установить("ПодробноеОписание","");
КонецЕсли;

Если Подключить()=0 Тогда
Возврат;
КонецЕсли;

Model=СписокМоделей.ПолучитьЗначение(СписокМоделей.ТекущаяСтрока());

LP45.TableType= 0; // Работаем с таблицей товаров
LP45.BeginAdd(); Здесь заменяю BeginAdd на SetRecord // Начинаем добавление

ТаблицаТоваров.ВыбратьСтроки();
Пока ТаблицаТоваров.ПолучитьСтроку()=1 Цикл

ПЛУ=ТаблицаТоваров.ПЛУ;

Если ПЛУ=0 Тогда
Продолжить;
КонецЕсли;

Сообщить("ПЛУ "+ПЛУ+" - ("+ТаблицаТоваров.ПрефиксШК+")"+Формат(ТаблицаТоваров.Код,"Ч(0)5")+" - "+ТаблицаТоваров.Наименование,"I");

LP45.PLU = ПЛУ;
LP45.Price = ТаблицаТоваров.Цена;
LP45.ICode = ТаблицаТоваров.Код;
LP45.Name = ТаблицаТоваров.Наим1;
LP45.Name2 = ТаблицаТоваров.Наим2;
LP45.MsgNo = 0;
LP45.Life = ТаблицаТоваров.СрокХранения;
LP45.Tare = ТаблицаТоваров.ВесТары;
LP45.GCode = ТаблицаТоваров.ПрефиксШК;
LP45.WareType = ТаблицаТоваров.ТипТовара;

Если (Model = 5) Тогда
LP45.LabelFont = LabelFont;
КонецЕсли;

LP45.SetRecord(); //Записываем запись в буффер
Если Ошибка()<>0 Тогда
Возврат;
КонецЕсли;
КонецЦикла;

LP45.EndAdd(); // Конец добавления
Если Ошибка()<>0 Тогда
Возврат;
КонецЕсли;

Ошибка.Установить("Описание", "");
Ошибка.Установить("ПодробноеОписание", "");
КонецПроцедуры


--------------------

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Добавить ответ в эту темуОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 8.12.2019, 20:31
 Яндекс цитирования  Rambler's Top100