IPB

Здравствуйте, гость ( Вход | Регистрация )

> Внимание!

Группа компаний «АТОЛ» информирует Вас о том, что с 4 июля 2011 года закрываются электронные форумы ГК «АТОЛ»,
посвященные дистрибутируемому и собственному оборудованию.
С 4 июля 2011 года данный раздел будет доступен только для чтения.

Для получения технической поддержки и сервиса мы рекомендуем всем партнерам зарегистрироваться в системе управления инцидентами Service Desk.

 
Добавить ответ в эту темуОткрыть тему
Сумма накладной не совпадает с суммой на чеке. Что за чудеса
ilyasia
сообщение 9.7.2010, 13:13
Сообщение #1


Прохожий


Группа: Новички
Сообщений: 7
Регистрация: 9.7.2010
Из: Челябинск
Пользователь №: 21 856



Приветствую.
Последние два дня творится сабж. Причем разница может быть довольно значительной (рекорд 30р). Единственно на что могу грешить, так это на внезапное вырубание электричества, которое имело место. Чек печатается следующим образом (если это поможет разобраться).

CODE
ТабЧасть.ВыбратьСтроки();
Пока ТабЧасть.ПолучитьСтроку()=1 Цикл
// продажа без сдачи
// регистрация продажи
ККМ.Name = ТабЧасть.Номенклатура.Наименование;
ККМ.Price = Число(ТабЧасть.Цена);
ККМ.Quantity = Число(ТабЧасть.Количество);
Если ККМ.Registration() <> 0 тогда
Предупреждение("Ошибка: "+ККМ.ResultCode+" "+ККМ.ResultDescription);
Возврат;
КонецЕсли;
КонецЦикла;
Итого=Число(ТабЧасть.Итог("Сумма"));
ККМ.Summ = Итого;
Если ККМ.Payment() <> 0 тогда
Предупреждение("Ошибка: "+ККМ.ResultCode+" "+ККМ.ResultDescription);
Возврат;
КонецЕсли;

Не сталкивался ли кто-нибудь с подобным? Как бороться?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Илья Золотарев
сообщение 9.7.2010, 13:25
Сообщение #2


выБывший
********

Группа: Пользователи
Сообщений: 2 996
Регистрация: 26.9.2007
Из: Москва
Пользователь №: 11 833



Цитата(ilyasia @ 9.7.2010, 14:13) *
Приветствую.
Последние два дня творится сабж. Причем разница может быть довольно значительной (рекорд 30р). Единственно на что могу грешить, так это на внезапное вырубание электричества, которое имело место. Чек печатается следующим образом (если это поможет разобраться).

CODE
ТабЧасть.ВыбратьСтроки();
Пока ТабЧасть.ПолучитьСтроку()=1 Цикл
// продажа без сдачи
// регистрация продажи
ККМ.Name = ТабЧасть.Номенклатура.Наименование;
ККМ.Price = Число(ТабЧасть.Цена);
ККМ.Quantity = Число(ТабЧасть.Количество);
Если ККМ.Registration() <> 0 тогда
Предупреждение("Ошибка: "+ККМ.ResultCode+" "+ККМ.ResultDescription);
Возврат;
КонецЕсли;
КонецЦикла;
Итого=Число(ТабЧасть.Итог("Сумма"));
ККМ.Summ = Итого;
Если ККМ.Payment() <> 0 тогда
Предупреждение("Ошибка: "+ККМ.ResultCode+" "+ККМ.ResultDescription);
Возврат;
КонецЕсли;

Не сталкивался ли кто-нибудь с подобным? Как бороться?

В логе Драйвера ККМ ошибки какие-нибудь были?


--------------------
экс-сотрудник АТОЛ
"Féci quód potuí, faciánt melióra poténtes" ©
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ilyasia
сообщение 9.7.2010, 13:34
Сообщение #3


Прохожий


Группа: Новички
Сообщений: 7
Регистрация: 9.7.2010
Из: Челябинск
Пользователь №: 21 856



Хм. Не догадался посмотреть, полез искать
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ilyasia
сообщение 9.7.2010, 13:56
Сообщение #4


Прохожий


Группа: Новички
Сообщений: 7
Регистрация: 9.7.2010
Из: Челябинск
Пользователь №: 21 856



За вчерашний день целый букет, например
CODE
08.07.2010 10:17:34 0000000000 Ошибка! ResultCode = -3 ResultDescription = "Порт недоступен (System Error. Code: 2.
Не удается найти указанный файл)" BadParam = 0 BadParamDescription = "Ошибок в параметрах нет"
0000000000 Driver.Set_DeviceEnabled 0
0000000000 Driver.Set_PortNumber 4

08.07.2010 10:17:55 0000000000 Ошибка! ResultCode = -1 ResultDescription = "Нет связи" BadParam = 0 BadParamDescription = "Ошибок в параметрах нет"
0000000000 Driver.Set_DeviceEnabled 0
08.07.2010 10:17:55 0000000000 Устройство включено = 0
0000000000 Waiting for EventThread...
0000000110 EventThread destroyed successfully
0000000015 Port closed
0000000000 Driver.Set_BaudRate 18
08.07.2010 10:17:55 0000000000 Скорость обмена = 18
08.07.2010 10:17:55 0000000000 Количество попыток установить связь = 2
0000000000 Driver.Set_DeviceEnabled -1
08.07.2010 10:17:55 0000000000 Устройство включено = 1
0000000000 Driver.Set_UseAccessPassword 0
08.07.2010 10:17:55 0000000000 Driver.GetDeviceMetrics
08.07.2010 10:17:55 0000000000 Посылка команды ККМ: 3F
0000000000 Получен ответ: 55 14 00
08.07.2010 10:17:55 0000000000 Ошибка! ResultCode = -3895 ResultDescription = "Неверная длина" BadParam = 0 BadParamDescription = "Ошибок в параметрах нет"
08.07.2010 10:17:55 0000000000 Driver.GetDeviceMetrics
08.07.2010 10:17:55 0000000000 Посылка команды ККМ: 3F
0000000000 Получен ответ: 55 14 00
08.07.2010 10:17:55 0000000000 Ошибка! ResultCode = -3895 ResultDescription = "Неверная длина" BadParam = 0 BadParamDescription = "Ошибок в параметрах нет"
0000000000 Driver.Set_UseAccessPassword -1
0000000000 Driver.Set_AccessPassword
08.07.2010 10:17:55 0000000000 Driver.GetDeviceMetrics
08.07.2010 10:17:55 0000000000 Посылка команды ККМ: 00 00 3F
0000000032 Получен ответ: 44 01 01 10 03 07 10 17 54 03 01 73 04 97 0F 32 34 01 03 54 00 06 00 00 00 00 00 00 02 01
08.07.2010 10:17:55 0000000000 Посылка команды ККМ: 00 00 A5
0000000000 Получен ответ: 00 01 01 0F 10 00 02 04 00 30 00 94 85 8B 88 8A 91 2D 30 32 8A
08.07.2010 10:17:55 0000000000 Driver.GetStatus
08.07.2010 10:17:55 0000000000 Посылка команды ККМ: 00 00 3F
0000000031 Получен ответ: 44 01 01 10 03 07 10 17 54 03 01 73 04 97 0F 32 34 01 03 54 00 06 00 00 00 00 00 00 02 01
0000000000 Driver.Set_DeviceEnabled 0
08.07.2010 10:17:55 0000000000 Устройство включено = 0
0000000000 Waiting for EventThread...
0000000109 EventThread destroyed successfully
0000000016 Port closed
0000000000 Driver.Set_Model 15
08.07.2010 10:17:55 0000000000 Driver.DeleteDevice
08.07.2010 10:17:55 0000000000 Разрушение объекта нижнего уровня
08.07.2010 10:17:55 0000000000 Объект старого протокола разрушен
################################################################
0000000000 Driver.Set_CurrentDeviceNumber 1
0000002578 Driver.Set_CurrentDeviceIndex 0
0000000000 Driver.Set_DeviceEnabled 0
0000000000 Driver.Set_CurrentDeviceIndex 0
0000000000 Driver.Set_CurrentDeviceIndex 0
0000000000 Driver.Set_CurrentDeviceIndex 0
0000002969 Driver.Set_CurrentDeviceIndex 0
0000000000 Driver.Set_CurrentDeviceIndex 0
0000000015 Driver.Set_Password 30
0000000000 Driver.Set_Caption Строка для печати
0000000000 Driver.Set_Value 0
0000000000 Driver.Set_Mode 0
0000000000 Driver.Set_TypeClose 0
0000000000 Driver.Set_CaptionPurpose 0
0000000000 Driver.Set_CaptionTable 0
0000000000 Driver.Set_ValuePurpose 0
0000000000 Driver.Set_Scale 100
0000000000 Driver.Set_PictureNumber 1
0000000000 Driver.Set_FileName
08.07.2010 10:18:00 0000000000 Driver.SaveDevicesSettings
0000001500 Driver.Set_DeviceEnabled -1
08.07.2010 10:18:02 0000000000 Устройство включено = 1
0000007500 Driver.Set_Hour 10
0000000000 Driver.Set_Minute 18
0000000000 Driver.Set_Second 9
0000000000 Driver.Set_Year 2010
0000000000 Driver.Set_Month 7
0000000000 Driver.Set_Day 8
08.07.2010 10:18:15 0000005797 Driver.SetTime
08.07.2010 10:18:15 0000000000 Посылка команды ККМ: 00 00 4B 10 18 09
0000000000 Получен ответ: 55 9C 00
08.07.2010 10:18:15 0000000000 Ошибка! ResultCode = -3837 ResultDescription = "Смена открыта - операция невозможна" BadParam = 0 BadParamDescription = "Ошибок в параметрах нет"
08.07.2010 10:18:19 0000003469 Driver.SetTime
08.07.2010 10:18:19 0000000000 Посылка команды ККМ: 00 00 4B 10 18 09
0000000016 Получен ответ: 55 9C 00
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Илья Золотарев
сообщение 9.7.2010, 14:15
Сообщение #5


выБывший
********

Группа: Пользователи
Сообщений: 2 996
Регистрация: 26.9.2007
Из: Москва
Пользователь №: 11 833



В данной части лога особо серьезных ошибок нет.
Важно наличие ошибок при пробитии чеков.


--------------------
экс-сотрудник АТОЛ
"Féci quód potuí, faciánt melióra poténtes" ©
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ilyasia
сообщение 9.7.2010, 14:20
Сообщение #6


Прохожий


Группа: Новички
Сообщений: 7
Регистрация: 9.7.2010
Из: Челябинск
Пользователь №: 21 856



Других не было. И еще. Что вообще в этот лог пишется? Почему-то за сегодняшний день записей вообще нет, хотя торговля была.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
АТОЛ: Царюков Ро...
сообщение 9.7.2010, 14:24
Сообщение #7


Тех.поддержка
********

Группа: Администраторы
Сообщений: 48 277
Регистрация: 25.9.2008
Из: Москва
Пользователь №: 14 717



Цитата(ilyasia @ 9.7.2010, 15:20) *
Других не было. И еще. Что вообще в этот лог пишется? Почему-то за сегодняшний день записей вообще нет, хотя торговля была.

версия драйвера какая?


--------------------

ответы на 90% вопросов находятся в ДОКУМЕНТАЦИИ
еще 9% ответов ТУТ
P.S.: уважайте труд наших писателей - читайте мануалы
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Илья Золотарев
сообщение 9.7.2010, 14:25
Сообщение #8


выБывший
********

Группа: Пользователи
Сообщений: 2 996
Регистрация: 26.9.2007
Из: Москва
Пользователь №: 11 833



Цитата(ilyasia @ 9.7.2010, 15:20) *
Других не было. И еще. Что вообще в этот лог пишется? Почему-то за сегодняшний день записей вообще нет, хотя торговля была.

В логе записываются все команды, отправляемые через Драйвер ККМ в аппарат, ответы и, соответственно, ошибки, возникающие при обмене.


--------------------
экс-сотрудник АТОЛ
"Féci quód potuí, faciánt melióra poténtes" ©
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ilyasia
сообщение 9.7.2010, 14:39
Сообщение #9


Прохожий


Группа: Новички
Сообщений: 7
Регистрация: 9.7.2010
Из: Челябинск
Пользователь №: 21 856



Цитата(АТОЛ: Царюков Роман @ 9.7.2010, 17:24) *
версия драйвера какая?

последняя, с этого сайта
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Добавить ответ в эту темуОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 4.4.2020, 11:26
 Яндекс цитирования  Rambler's Top100