IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Добавить ответ в эту темуОткрыть тему
Не выгружаются продажи из Бастиона 10 в 1с.
ИльяТомск
сообщение 18.6.2007, 10:24
Сообщение #1


Прохожий


Группа: Пользователи
Сообщений: 12
Регистрация: 12.12.2006
Из: Томск
Пользователь №: 9 861



ТВД Бастион 10, прошивка 1.77.

Забираю продажи из ТВД Бастион 10. Количество проданного товара равно 0. Проверяю продажи в демке для 1с, которая идёт вместе с драйвером, там тоже равно 0. Проверяю в драйвере Memoplus, там нажимаю кнопку «Работа с товарами 1» флаг продажи есть, а количество 0. Нажимаю кнопку «Работа с товарами 2», там в графе «Кол-во проданного:» продаж 2. Не знаю с чем связанно.
Высылаю код в 1с:

Если ЗагрузитьВнешнююКомпоненту("MP31C.dll")<>0 Тогда //Загрузка внешней компоненты
Memo = СоздатьОбъект("AddIn.MP345"); // Создание объекта из внешней компоненты
Сообщить("Внешняя компонента Memo - MP31C.dll загружена ",5);
Проверкарежима=1;
Иначе
Сообщить("Внешняя компонента Memo - MP31C.dll не найдена",5);
КонецЕсли;
Memo.DeviceEnabled=1;
Если ГАШ = 1 Тогда
memo.ReportType = 2;
иначе
memo.ReportType = 1;
КонецЕсли;



Err = Memo.BeginReport(); // Начать снятие отчета ККМ
Пока Err=0 Цикл
Err = Memo.GetRecord(); // Чтение очередной записи отчета
Если Err=0 Тогда
со.НоваяСтрока();
со.сПЛУ=Memo.PLUNumber;
со.сШК=Memo.BarCode;
со.сСекция=Memo.Department;
со.сНалог=Memo.Tax;
со.сЦена=Memo.Price;
со.сТовар=Memo.Name;
со.сКоличество=Memo.Количество;//Memo.Quantity;
//Quantity=Memo.Количество;
со.сСумма=Memo.Summ;
со.сОстаток=Memo.Rest;
//Rest=Memo.Остаток;
со.сОтложенно=Memo.IsBuffered;
со.сУдалено=Memo.IsDeleted;
со.сЗаблокированно=Memo.IsLocked;
со.сПродано=Memo.IsSold;
// АктивизироватьСтроку();
КонецЕсли;
КонецЦикла;
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Добавить ответ в эту темуОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 20.9.2019, 7:17
 Яндекс цитирования  Rambler's Top100