IPB

Здравствуйте, гость ( Вход | Регистрация )

> Внимание!

Группа компаний «АТОЛ» информирует Вас о том, что с 4 июля 2011 года закрываются электронные форумы ГК «АТОЛ»,
посвященные дистрибутируемому и собственному оборудованию.
С 4 июля 2011 года данный раздел будет доступен только для чтения.

Для получения технической поддержки и сервиса мы рекомендуем всем партнерам зарегистрироваться в системе управления инцидентами Service Desk.

 
Тема закрытаОткрыть тему
Возврат оплаты безналом в чеке
Mitrich
сообщение 25.10.2005, 12:43
Сообщение #1


Прохожий


Группа: Пользователи
Сообщений: 6
Регистрация: 25.10.2005
Пользователь №: 1 150



1С УТ 8.0 + атоловский общий драйвер ККМ 5.15.0.3855
Стандартная обработка 1С криво с оплатой безналом работает, пытаюсь переделать:

//Регистрация продажи/возврата (для каждой строки чека в цикле):
Объект.Name = Лев(СтрокаИзСписка.Товар, ДлинаНаименования);
Объект.Price = СтрокаИзСписка.Цена;
Объект.Quantity = СтрокаИзСписка.Колво;
Если ПризнВозврата Тогда
Объект.Return();
Иначе
Объект.Registration();
КонецЕсли;

//Регистрация платежа:
Если ПолученоНал > 0 Тогда
Объект.Summ = ПолученоНал;
Объект.TypeClose = 0;
Объект.Payment();
КонецЕсли;
Если ПолученоБезНал > 0 Тогда
Объект.Summ = ПолученоБезНал;
Объект.TypeClose = 1;
Объект.Payment();
КонецЕсли;

Объект.Department = НомерСекции;
Объект.CloseCheck();
Объект.GetStatus();

При покупке все нормально, в чеке 2 строчки оплаты. При возврате (даже всего товара) - ошибка -3810 (Накопление меньше суммы возврата или аннулирования) после вызова метода Объект.Return()

ПолученоНал = ОбщаяСуммаПоЧеку - ПолученоБезНал
ПолученоНал и ПолученоБезНал одни и те же и при покупке, и при возврате. Если ПолученоБезНал=0, то все нормально работает.
И что я делаю не так?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Mitrich
сообщение 25.10.2005, 14:34
Сообщение #2


Прохожий


Группа: Пользователи
Сообщений: 6
Регистрация: 25.10.2005
Пользователь №: 1 150



Типа разобрался (хвала Т1С на Кубани).
При возврате по умолчанию идет в драйвере проверка на наличность в кассе, причем ДО вызова метода Paiment(), т.е. драйвер на самом деле не проверяет, идет возврат наличкой или безналом, а считает все наличкой.
Нехорошо это. Неправильно. smile.gif
Теперь придется в коде в 1C бяку ставить:

Если ПолученоБезНал > 0 Тогда
Объект.EnableCheckSumm = "FALSE";
Иначе
Объект.EnableCheckSumm = "TRUE";
КонецЕсли;

PS Отдельное спасибо 1С за ошибки в типовых конфах.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
АТОЛ: Владимир
сообщение 25.10.2005, 15:39
Сообщение #3


ГК «АТОЛ»
********

Группа: Администраторы
Сообщений: 4 425
Регистрация: 11.1.2005
Из: Москва
Пользователь №: 53



1) Данные проверки делает не драйвер, а сама ККМ на аппаратном уровне.
2) Специально для отключения контроля наличности при использовании неналичных видов оплат и придумано свойство EnableCheckSumm, а точнее такой механизм в ККМ. Дело в том что ККМ контролирует возвращаемую сумму в двух местах, при каждой регистрации и при закрытии чека. Так вот на этапе регистраций еще не известно каким видом оплаты вы будете расплачиваться поэтому касса и контролирует наличные, что собственно легко отключается свойством EnableCheckSumm. При закрытии чека касса в любом случае проконтролирует возвращаемую сумму уже с учетом сделанных платежей - что собственно в основном и нужно.

Так что ставьте всегда EnableCheckSumm = FALSE и читайте внимательнее документацию :wink: .


--------------------
!!! Пожалуйста, указывайте версии используемого ПО, ОС и модели оборудования !!!
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Mitrich
сообщение 25.10.2005, 16:23
Сообщение #4


Прохожий


Группа: Пользователи
Сообщений: 6
Регистрация: 25.10.2005
Пользователь №: 1 150



Спасибо за разъяснения.
Обязательно перешлю рекомендации внимательно читать документацию разработчикам фирмы 1С smile.gif
Косяки их, а я голову ломаю, думать лишний раз приходится :grin:
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Тема закрытаОткрыть тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 22.9.2019, 7:38
 Яндекс цитирования  Rambler's Top100