Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Типы оплат ТИС 77 и обработка Fr_comm.ert
Форумы общения пользователей продуктов АТОЛ > FPrint, EasyPOS Lite, Феликс, Бастион, Торнадо, Flaton > ФЕЛИКС-Р Ф
arimar
День добрый! только вот не давно начал разбираться с 1С , Проблемка такая надо прикрутить в 1С ТИС 77 , чтобы можно было через обработку fr_comm.ert на принтер ЕНВД в чеке выводить разные типы оплаты!
Предыдущие топики которые были почитал!
1) http://forum.atol.ru/index.php?showtopic=1...ghlight=payment
2)http://forum.atol.ru/index.php?showtopic=1304&highlight=payment
почти все не понятно, может подскажите
если я буду писать в коде 1С обработке fr_comm.ert
CODE
Если (Получено > 0) И (Получено > СуммаЧека) Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ТипЗакрытия = 0;
Объект.Оплата();
Иначе
Объект.ЗакрытьЧек();
КонецЕсли;
Если ПолученоБезнал > 0 Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ТипЗакрытия = 1;
Объект.Оплата();
Иначе
Объект.ЗакрытьЧек();
КонецЕсли;

или же вот так

КонецЕсли;
CODE
Если (Получено>0) И (Получено>СуммаЧека) Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ОплатаСоСдачей();
ИначеЕсли ПолученоБезнал <> 0 Тогда
Объект.Summ = Окр(Получено,2,1);
Объект.ТипЗакрытия = 1;
Объект.Payment();
Иначе
Объект.ЗакрытьЧек();
КонецЕсли;


Да и зачем указывать метод Payment()? я так понял если у нас смешанный тип оплаты то тогда, а если не используется то можно ли просто написать ЗакрытьЧек()
?????????
arimar
Все решилось! wink.gif))) ну конечно тема не из этой ветки! Всего то требоввалось пару строчек кода написать!
Можно закрывать тему!
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Русская версия IP.Board © 2001-2021 IPS, Inc.