Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Чеки с удвоенной суммой
Форумы общения пользователей продуктов АТОЛ > FPrint, EasyPOS Lite, Феликс, Бастион, Торнадо, Flaton > ФЕЛИКС-Р Ф
Vladuha
Фискальник работает с 1С:Торговля+Склад. Иногда выходят чеки с удвоенной суммой, т.е. берет покупатель товар на 30, а в чеке итоговая сумма 60. В 1С в Чеке ККМ сумма нормальная. В чем может быит проблема?
Гольдер Дмитрий
Включите ведение ЖУРНАЛА в настройках драйвера. Скорее всего проблема в Обработке для ФР
Vladuha
ок, а куда он будет записываться? в каталог с базой?
Гольдер Дмитрий
в каталог в котором зарегистрирована библиотека FprnM1C.dll
Torin®
СервисПараметрыОбщий драйвер ККМ

Параметры оборудования пароль ** Печать чека

Количество товара на КЛ установите ПЕЧАТАТЬ ЛЮБОЕ.

И если вы в таких ситуация просмотрите контрольную ленту то легко найдете ошибку обратки обслуживания Fr_comm.ert
Vladuha
удваивается сумма, а не количество. Один раз было, что закончилась лента при проведении чека, вставили новую. Чек вышел с надписью чек аннулирован, а потом новый чек на ленте с тем же товаром, только итоговая сумма удвоенная. Хотя ведь предыдущий был аннулирован, у девочек-операторов обычно это вызывает панику
Torin®
Посмотрим как обстоят дела изнути у обработки обслуживания фискального регистратора

РезРегистрация = 1;
СписокТоваров.ВыбратьСтроки();

ДлинаНаименования = Объект.ДлинаСтрокиСимволов; // зависит от модели ФР
Вот отсюда начинаяется перебо строк и документа ЧЕК

Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл

Объект.Name = Лев(СписокТоваров.ТовНаим,ДлинаНаименования);
Объект.Price = Окр(СписокТоваров.Цена,2,1);

Цену на чеке ФР печатает правильную?

Объект.Quantity = СписокТоваров.Количество;
Количество на чеке ФР печатает правильное?


Если ПризнВозврата = 0 Тогда
Объект.Регистрация();
Иначе
Объект.Возврат();
КонецЕсли;

Если Объект.Результат <> 0 Тогда
ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
Попытка
Объект.CancelCheck();
Исключение
КонецПопытки;
Возврат 0;
КонецЕсли;
КонецЦикла;

ФР сам просчитывает формулу Сумма=Цена*Количество

У вас ошибка в обработке обслуживания ФР

можете выслать его на e-mail ( указан в профиле) постораюсь помочь
АТОЛ: Владимир
Сделайте перед началом чека отмену чека. Видимо предыдущий чек не был закрыт (например, бумага кончилась) и следовательно в ФР регистрации остались и к ним добавились новые при повторной попытке пробития чека.
Vladuha
вроде нашел баг в обработке - попробую, может заработает, спасибо за помощь
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Русская версия IP.Board © 2001-2022 IPS, Inc.